神州数码DCWS-6002无线控制器使用option43方式注册上线并配置WiFi

准备工作

secuerCRT,com串口线*1,
由于AC只有两个接口,故eth1/0/1用于汇聚上层,eth1/0/2用于管理AP

第一步,创建vlan

分别是vlan10,管理AP;vlan20,无线用户分配IP;vlan30,用于汇聚上层
AC进入全局模式输入:

AC(config)#vlan 10;20;30
AC(config)#int vlan 10
AC(config-if-vlan10)#ip address 192.168.10.1 255.255.255.0
AC(config-if-vlan10)#!
AC(config)#int vlan 20
AC(config-if-vlan20)#ip address 192.168.20.1 255.255.255.0
AC(config-if-vlan20)#!
AC(config)#int vlan 30
AC(config-if-vlan30)#ip address 192.168.30.1 255.255.255.0
AC(config-if-vlan30)#!

第二步,设置trunk让数据可以进入到AP

也是在全局模式下输入:

AC(config)#interface ethernet 1/0/2
AC(config-if-ethernet1/0/2)#switchport mode trunk
AC(config-if-ethernet1/0/2)#switchport trunk allowed vlan 10;20;30
AC(config-if-ethernet1/0/2)#switchport trunk native vlan 10 //此为AP管理vlan
Set the port Ethernet1/0/2 native vlan 30 successfully
AC(config-if-ethernet1/0/2)#exit

截图有一个错误的地方switchport trunk native vlan 30 ←这个应该是VLAN10,我打错了QAQ

第三步,开启dhcp并配置无线管理vlan

全局模式输入:

AC(config)#service dhcp
AC(config)#ip dhcp pool APadmin //后面的APadmin是该dhcp的名称,请按照试题要求填写
AC(dhcp-apadmin-config)#network-address 192.168.10.0 255.255.255.0 //这个是无线管理vlan的网段
AC(dhcp-apadmin-config)#default-router 192.168.10.1 //这个是该网段的网关
AC(dhcp-apadmin-config)#dns-server 114.114.114.114 //dns服务器地址
AC(dhcp-apadmin-config)#option 43 hex 0104c0a80a01 //此为16进制的网关IP 192.168.10.1,其中开头的0104是必须要填的,之后才填16进制的IP地址
DHCPD: Option 43 has been added to pool APadmin
AC(dhcp-apadmin-config)#exit

第四步,配置AP的dhcp用于WiFi连接分配IP地址

在全局模式下输入:

AC(config)#ip dhcp pool AP1
AC(dhcp-ap1-config)#network-address 192.168.20.0 255.255.255.0
AC(dhcp-ap1-config)#default-router 192.168.20.1
AC(dhcp-ap1-config)#dns-server 114.114.114.114
AC(dhcp-ap1-config)#exit
AC(config)#ip dhcp pool AP2
AC(dhcp-ap2-config)#network-address 192.168.30.0 255.255.255.0
AC(dhcp-ap2-config)#default-router 192.168.30.1
AC(dhcp-ap2-config)#dns-server 114.114.114.114
AC(dhcp-ap2-config)#exit

第五步,配置开启WiFi

在全局模式输入:

AC(config)#wireless
AC(config-wireless)#enable //开启无线功能
AC(config-wireless)#no auto-ip-assign //关闭ap认证
AC(config-wireless)#static-ip 192.168.10.1 //指向无线管理vlan
AC(config-wireless)#network 1 //进入无线配置模式1
AC(config-network)#security mode wpa-personal //无线加密模式
AC(config-network)#wpa key 12345678 //无线密码
AC(config-network)#ssid test //无线显示名称
AC(config-network)#vlan 20 //分配IP的vlan
AC(config-network)#exit

到这里就配置完成了,此时将AP连接到eth1/0/2接口,等待AP上的指示灯从绿色变为蓝色既表示成功。

文章作者: Timo在此
文章链接: https://bbs.xiao-xin6.cn/archives/118
版权声明: 本博客所有文章除特别声明外,均采用 CC BY-NC-SA 4.0 许可协议。转载请注明来自 Timo在此!

评论

  1. Windows Edge
    1 年前
    2023-4-05 13:05:07

    艹,在必应上面搜东西无意中找到你这个,留个记号

  2. someone
    Windows Edge
    7 月前
    2023-12-06 19:02:31

    这个配置不用option 43 也能上线吧

    • Timozaici
      博主
      someone
      Windows Chrome
      7 月前
      2023-12-06 19:20:06

      当时玩的时候给我的感觉就是这AP很迷,有时候什么配置都没有它也能上线,有时候什么都配置了它就是不上线,已经放弃折腾了

发送评论 编辑评论


				
|´・ω・)ノ
ヾ(≧∇≦*)ゝ
(☆ω☆)
(╯‵□′)╯︵┴─┴
 ̄﹃ ̄
(/ω\)
∠( ᐛ 」∠)_
(๑•̀ㅁ•́ฅ)
→_→
୧(๑•̀⌄•́๑)૭
٩(ˊᗜˋ*)و
(ノ°ο°)ノ
(´இ皿இ`)
⌇●﹏●⌇
(ฅ´ω`ฅ)
(╯°A°)╯︵○○○
φ( ̄∇ ̄o)
ヾ(´・ ・`。)ノ"
( ง ᵒ̌皿ᵒ̌)ง⁼³₌₃
(ó﹏ò。)
Σ(っ °Д °;)っ
( ,,´・ω・)ノ"(´っω・`。)
╮(╯▽╰)╭
o(*////▽////*)q
>﹏<
( ๑´•ω•) "(ㆆᴗㆆ)
😂
😀
😅
😊
🙂
🙃
😌
😍
😘
😜
😝
😏
😒
🙄
😳
😡
😔
😫
😱
😭
💩
👻
🙌
🖕
👍
👫
👬
👭
🌚
🌝
🙈
💊
😶
🙏
🍦
🍉
😣
Source: github.com/k4yt3x/flowerhd
颜文字
Emoji
小恐龙
花!
上一篇
下一篇